NOTE

Dear Mac users: to run the Betaville.app under Mavericks, you will have to install/re-install Java. The Oracle installer will NOT work for you! To get up and running, use the Apple installer available at http://support.apple.com/kb/dl1421.

Maya Modeling Tutorial

by Levis Reyes - October 20, 2010

Introduction

This tutorial will guide you through the necessary steps to get Autodesk Maya to export models ready to be imported into Betaville.

NOTE

As of Maya 2013, the built-in DAE-FBX exporter will generally export satisfactory Collada files for use in Betaville. If you find that the exported .dae file won't open in Preview on a Mac, or otherwise tells you it isn't a correct .dae file, you may find that importing it into Sketchup and then right back out will fix the problem.

Exporter Setup

You will need to setup a Collada exporter in order to export the correct model format.

  • Download the either the OS X or Windows (32 or 64-bit) version depending your operating system.
  • Run the executable installer that you just downloaded. This will check compatibility with your installation of Maya and install the plugin.

We now need to setup the exporter from within Maya so that the right options are selected

  • Start Maya
  • Go to Window → Settings/Preferences → Plugin-in Manager
  • Ensure that the COLLADA plugin is set to 'Loaded' as well as 'Auto load'
  • Close the Plug-in Manager and open the export options window: File → Export Selection (select the square on the right side of the menu option)
  • With the Export Selection Options window open, set up the window as seen in the image
  • Select Apply, followed by Close.

Next we will want to ensure that we are working in a desirable unit of measure

  • Go to Window → Settings/Preferences → Preferences
  • On the left side of the window select 'Settings' from the list of Categories
  • Select Y as your up-axis and foot [or meter] as your Linear Working Unit

Now let's make sure that the grid is sized accordingly

  • If it isn't already, enable the grid by selection Display → Grid
  • Now select the grid options panel by selection the small square to the right of the Display → Grid menu item
  • With the grid options open you may customize the size and line increments of the grid based on the project you're embarking on. These options can be changed at any time.
  • Note the size in the grid quadrants as seen in the image

Now we will go through the steps of preparing a design for export.

  • With the object selected and in Translate mode (hit the W key), Holding down the letter “D” on your keyboard will make the Gizmo change to what is shown above. Holding down “D” is gives you the option to move the gizmo anywhere in space without snapping to anything. But, what we want is to snap to one of the lower corners.
  • By holding down “D” and “V” simultaneously on your keyboard you will initiate the option to snap to points. Notice how the middle of the gizmo changes from a square to a circle when you hold down both D and V. Now, select and drag the x,y,zgizmo anywhere around the object. Notice how when you grab the gizmo by the middle (the yellow) you can move it easier than when you try moving it by one of the gizmo’s legs. Always use the middle of the gizmo when trying to snap to a certain location, it is much easier.
  • For Betavilleit is preferred to move the gizmo to one of the lower corners just like in this image. This will allow the object to be flush with the terrain once it is uploaded into Betaville.
  • The next step would be to try and bring the object to Zero intercept on the axis.
  • To do this, first turn on the axis snap by clicking on the grid icon the orange arrow is pointing at on this image.
  • If done correctly, your design should now be at the zero location on the axis (see image above)
  • Almost done! Let's just freeze the transformations.
  • It is important that we freeze the object’s transformations so that when we upload it into Betavillethe object behaves accordingly, and doesn’t appear somewhere else other than the spot we selected in Betaville. After these few steps all the numbers on the channel box (the box highlighted with orange) will be set to zero automatically.
  • Go to Modify→FreezeTransformation -select the small square on the right -this will bring up the transformation options.
  • Make sure the Freeze transformation Options window has everything that appears on the above image selected.
  • * Check :
  • * * Translate, Rotate, Scale, Joint Orient
  • Hit “Apply” followed by “Freeze transform” and notice how everything turns to zero on the Channel box window to the right.

Now we are ready to export

  • Go to File → Export Selection
  • The browse window now appears, select the folder where your textures, if any, are located.
  • From the file-type drop down select Collada.
  • Click Export!

Now we will import the model into Betaville!