[DEPRECATED] Welcome Developers!

Do you want to write a module for Betaville? Do you want to fix a bug? Maybe you just want to see what the innards look like! You've come to the right place.

Betaville is available under the free and open source BSD License.

This tutorial will teach you how to check out the sources and run the Betaville application from within Eclipse IDE. If you're using Netbeans IDE, click here

Setting up Eclipse

If you don't have it already, run and grab the Eclipse IDE for Java Developers. Once its running, you will want to install a Subversion client. For those not familiar with Subversion it is what's known as a Version Control System, which allows us to keep track of code changes by different developers.

To install a Subversion client within Eclipse:

  1. Help menuInstall New Software
  2. Select Helios (or Galileo, or Ganymede depending on your version of Eclipse) from the “Work with:” drop down menu
  3. You will find SVN Team Provider under the list of plugins called “Collaboration”.
  4. Select this plugin and click through the next steps to install it.
  5. When you are prompted to restart Eclipse, do so, and you will be offered the option of SVN drivers when Eclipse opens again. The SVNKit option works pretty well on all operating systems. (You can install all versions of it without issue)

Accessing Google Code

The sources for Betaville are hosted on Google Code. The page there isn't actively maintained, but is used mostly for the provided Subversion hosting.

To access the sources from within Eclipse:

  1. Window menuOpen PerspectiveOther
  2. From this window, select SVN Repository Exploring.
  3. On the left side of the screen there should be a tab for “SVN Repositories”, right click in here and select NewRepository Location
  4. Under URL, put “http://betaville.googlecode.com/svn” (committers see developer_checkout) and click Finish.
  5. Expand the newly created repository entry as well as the BetavilleApp folder.
  6. Right clickCheck Out the trunk folder.

Congratulations! Once this process is completed you now have all of the code necessary to build and run Betaville on your computer. Now to run it…

Running the Application

Ok, now lets make Betaville go!

  1. From the Java perspective (Window menu → Open Perspective → Java), expand the BetavilleApp project.
  2. You will see a number of items here, but we only need to concern ourselves with the src folder, go ahead and expand it.
  3. Locate the package called 'edu.poly.bxmc.betaville.jme' and expand it as well.
  4. Right click on the entry called 'BetavilleNoCanvas.java' and select Run AsRun Configurations
  5. Under the VM Arguments tab, enter “Xmx768M” into the second text box under the heading “VM Arguments”
  6. Accept and close the windows, and once again *right click BetavilleApp, selecting Run AsJava Application Betaville should open now and run against the latest code checked out from the repository. In order to keep your local copy up to date, be sure to run an SVN update from within Eclipse by right clicking the BetavilleApp project and selecting TeamUpdate**

If you just read through all of this and are more confused then ever, I would highly recommend checking out the quickstart tutorial :)